在Eclipse中配置tomcat .

2014-01-26 14:20

为了在Eclipse中进行struts2的测试,才发现自己机器上的Eclipse没有集成Tomcat,在网上找了半天,不是这个插件没有下载地址,就是那个有好多注意事项或者版本问题。 结果,自己到tomcatforEclipse的插件的网上直接下载了一个,按照提供的说明一下子就配成了。 网上的那么多配置文章,唉,不说啥了。 看看我的配置步骤吧。 1,Eclipse的安装。这个是从Eclipse的官方网站下载的。不用教吧,下载后exe文件执行安装。我的版本是, Eclipse SDK Version: 3.4.2 Build id: M20090211-1700 2,下载一个tomcat,从apache的官方网站上下载一个,我下的是,6.x版本,文件名为:apache-tomcat-6.0.20.exe 地址http://tomcat.apache.org/download-60.cgi,下载windows版的,下载后exe文件一溜安装,安装内容部分的选项全选,其他全部默认配置,中间有个admin密码的地方,输入你自己设定的密码即可。 安装后启动,靠,启动不了。原来安装时候,机器上用的是jre6,tomcat使用的也是jre6,好像不支持,那好下载一个jdk5,从sun的官方网站下载, 我下的是jdk-1_5_0_19-nb-6_5_1-windows-ml.exe,集成netbean的版本,下载后一路默认安装。 安装完了,卸载tomcat,重新安装,jre的部分制定成jre1.5,安装完了后,服务启动tomcat,浏览器输入,http://localhost:8080/,ok,页面出来正常表示。 3,下载tomcat对eclipse的插件。 下载地址:http://www.eclipsetotale.com/tomcatPlugin.html 这个页面还有,安装说明的,英语好的可以自己看看。 我下的这个;tomcatPluginV321.zip 下载后,解压。解压后的文件放到eclipse的plug目录中,如图。 然后启动eclipse,看到三个图标了吧,如图 这个时候点三个图标,出现提示告诉你不行。 还需要配置tomcat的版本,和tomcat的home,参考图, 配置完毕,应用按钮按下,关闭,然后先从window的服务中停止tomcat的服务, 回到eclipse的页面,点那三个图标,ok了吧,下面的console的窗口有反映了吧, 然后打开浏览器,http://localhost:8080/ ok了,tomcat启动了 最后,总结,很简单,配置。自己动手很快,照着网上的那些教程倒是容易给人绕糊涂,但是,说归说,我这边文章也是参考了网上的部分教程