Tomcat部署应用后报错

2017-04-27 18:26

今天导入以前开发的一个项目之后,将项目add到tomcat之后,启动tomcat报如上错误。

问题的来源:tomcat使用的是7.0,而jre使用的是1.8

解决的办法:在eclipse中配置tomcat的时候需要配置一个jre环境,将其设置为1.7,然后将项目的jre环境也设置为1.7,成功解决,目前还不了解为什么,可能是tomcat7.0的某些功能与jdk1.8不兼容。